Outage
Incident Report for Blaze Verify
Resolved
This issue has been identified and resolved. All services have been restored.
Posted Sep 18, 2020 - 12:42 EDT
Investigating
We are currently investigating this issue.
Posted Sep 18, 2020 - 12:34 EDT
This incident affected: API and Dashboard.