List Verification Delays
Incident Report for Blaze Verify
Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 18:27 EST
Investigating
We are currently investigating this issue.
Posted Feb 12, 2020 - 17:32 EST
This incident affected: Dashboard.