Outage
Incident Report for Blaze Verify
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 15:57 EDT
Investigating
We are experiencing an outage caused by our hosting provider. We are in contact with them and they are working on resolving the issue.
Posted Mar 16, 2020 - 15:50 EDT
This incident affected: API and Dashboard.